Chyba zásuvky #11001: Host nebyl nalezen
Příznaky
- Stav vzdáleného počítače je v Vieweru zobrazen jako „Offline“ v adresáři.
- Můžete navázat vzdálené připojení, ale připojení je nestabilní.
Když zkontrolujete Host log (nebo Agent log, pokud je používán Agent), uvidíte následující chybu: Chyba zásuvky # 11001 Host nebyl nalezen.(EIdSocketError)
Příčina
Tato chyba znamená, že vzdálený Host nebo Agent není k dispozici z jedné z těchto příčin:
- Problém s DNS, tj. IP adresa zprostředkovatelského serveru není schopna být převedena z jejího DNS názvu.
- Adresa zprostředkovatelského serveru nebo výstupní porty jsou blokovány firewallem.
Jak je citováno v Chybové kódy Windows Sockets:
WSAHOST_NOT_FOUND
11001
Host nebyl nalezen.
Žádný takový host není znám. Název není oficiální jméno hostitele nebo alias, nebo ho nelze nalézt v dotazovaných databázích. Tato chyba může být také vrácena pro dotazy na protokol a službu, a znamená, že zadané jméno nebylo nalezeno v příslušné databázi.
Řešení 1: Vymazat cache DNS
- Stiskněte Win+R, abyste otevřeli dialog Spustit.
- Do pole zadejte
ipconfig /flushdns
a klikněte na OK (nebo stiskněte Enter), abyste vymazali cache DNS: - Pravým tlačítkem klikněte na ikonu Host v oblasti tray a vyberte Restartovat hostitele. Počkejte 10-20 sekund, než se Host restartuje a připojí zpět k zprostředkovatelskému serveru.
Řešení 2: Zkontrolujte konektivitu s naším veřejným serverem
Pokud používáte naši veřejnou službu Internet-ID, ujistěte se, že primární server na id.remoteutilities.com
je přístupný z počítače Host a IP adresa serveru může být úspěšně vyřešena.
- Stiskněte Win+R, abyste otevřeli dialog Spustit.
- Do pole zadejte
cmd
a klikněte na OK (nebo stiskněte Enter). Otevře se příkazový řádek. - Do pole zadejte
ping id.remoteutilities.com
a stiskněte Enter. - Pokud je příkaz ping a DNS resoluce úspěšná, výsledek bude zobrazen v okně CMD:
- Pokud obdržíte jako odpověď „Vypršení časového limitu požadavku“, server ID není možné dosáhnout z umístění Host. Prosím, kontaktujte svého správce systému.
Řešení 3: Ujistěte se, že je povoleno odchozí připojení
Připojení Internet-ID vyžaduje, aby některé odchozí porty byly otevřeny. Když je používáno s naší veřejnou službou, používají se porty TCP 5655 a 443. Ujistěte se, že Host může navazovat odchozí připojení na těchto portech nebo povolte porty v místním a obvodovém firewallu, je-li to nutné.
I když jsou odchozí připojení na TCP portech 5655 a 443 povolena na stroji Host a v obvodovém firewallu, taková připojení mohou být stále blokována na úrovni ISP. V tomto případě byste měli kontaktovat svého zástupce ISP.