Socketfejl #11001: Vært ikke fundet
Symptomer
- Status for fjerncomputeren vises som "Offline" i Viewer adressebogen.
- Du kan oprette en fjernforbindelse, men forbindelsen er ustabil.
Når du undersøger Host-loggen (eller Agent-loggen, hvis Agent anvendes), ser du følgende fejl: Socketfejl # 11001 Vært ikke fundet.(EIdSocketError)
Årsag
Denne fejl betyder, at den fjerne Host eller Agent ikke er tilgængelig på grund af en af disse grunde:
- DNS-problem, dvs. IP-adressen til mellemserveren kan ikke findes fra dens DNS-navn.
- Mellemserverens adresse eller udgående port er blokeret af firewallen.
Som citeret fra Windows Sockets Fejlkoder:
WSAHOST_NOT_FOUND
11001
Vært ikke fundet.
Ingen sådan vært kendes. Navnet er ikke et officielt værtsnavn eller alias, eller det kan ikke findes i de database(r), der forespørges. Denne fejl kan også returneres for protokol- og serviceforespørgsler og betyder, at det specificerede navn ikke kunne findes i den relevante database.
Løsning 1: Ryd DNS-cachen
- Tryk på Win+R for at åbne dialogboksen Kør.
- Skriv
ipconfig /flushdns
og klik på OK (eller tryk på Enter) for at rydde DNS-cachen: - Højreklik på Host-ikonet i tray-området og vælg Genstart Host. Vent 10-20 sekunder, indtil Host genstarter og opretter forbindelse til mellemserveren.
Løsning 2: Tjek forbindelsen med vores offentlige server
Hvis du bruger vores offentlige Internet-ID-tjeneste, skal du sikre dig, at den primære server på id.remoteutilities.com
kan tilgås fra Host-PC'en, og at serverens IP-adresse kan opløses med succes.
- Tryk på Win+R for at åbne dialogboksen Kør.
- Skriv
cmd
og klik på OK (eller tryk på Enter). Kommandoprompten åbnes. - Skriv
ping id.remoteutilities.com
og tryk på Enter. - Hvis ping-kommandoen og DNS-opløsningen er succesfulde, vises resultatet i CMD-vinduet:
- Hvis du modtager "Anmodning timed out" som svar, kan ID-serveren ikke nås fra Hostens placering. Kontakt venligst din systemadministrator.
Løsning 3: Sørg for, at udgående forbindelser er tilladt
Internet-ID-forbindelsen kræver, at nogle udgående porte er åbne. Når den bruges med vores offentlige tjeneste, er de anvendte porte TCP 5655 og 443. Sørg for, at Host kan oprette udgående forbindelser på disse porte, eller tillade portene i den lokale og perimeter firewall, hvis det er nødvendigt.
Selv hvis udgående forbindelser på TCP-porte 5655 og 443 er tilladt på Host-maskinen og i perimeter-firewallen, kan sådanne forbindelser stadig være blokeret på ISP-niveau. I dette tilfælde bør du kontakte din ISP-repræsentant.