שגיאת Socket #11001: המארח לא נמצא

סימפטומים

  • סטטוס המחשב המרוחק מוצג כ"לא מקוון" בפנקס הכתובות של ה-Viewer .
  • אתה יכול לקבוע חיבור מרוחק, אך החיבור לא יציב.

כאשר אתה בודק את יומן ה-Host (או יומן ה-Agent, אם ה-Agent בשימוש) אתה רואה את השגיאה הבאה: שגיאת Socket # 11001 המארח לא נמצא.(EIdSocketError)


סיבה

שגיאה זו מציינת כי ה-Host או ה-Agent המרוחקים אינם זמינים בגלל אחת מהסיבות הבאות:

  • בעיית DNS, כלומר, כתובת ה-IP של השרת הביניים אינה ניתנת לפתירה משם ה-DNS שלו.
  • כתובת השרת הביניים או יציאות החיבור חסומות על ידי חומת האש.

כפי שנאמר ב- קודי שגיאה של Windows Sockets:

WSAHOST_NOT_FOUND
11001
המארח לא נמצא.
לא ידוע מארח כזה. השם אינו שם מארח רשמי או כינוי, או שאין ניתן למצוא אותו במסד הנתונים שנבדק. שגיאה זו עשויה להיבחר גם עבור שאלות פרוטוקול ושירות, ואומרת כי השם שצוין לא נמצא במסד הנתונים הרלוונטי.


פתרון 1: נקה את מטמון ה-DNS

  1. לחץ על Win+R כדי לפתוח את חלון "הריצה".
  2. הקלד ipconfig /flushdns ולחץ OK (או הקש Enter) כדי לנקות את מטמון ה-DNS: ניקוי DNS
  3. לחץ עם העכבר על אייקון ה-Host באזור המגש ובחר אתחל את ה-Host. המתן 10-20 שניות עד שה-Host יתאושש ויתחבר חזרה לשרת הביניים.

פתרון 2: בדוק את החיבוריות עם השרת הציבורי שלנו

אם אתה משתמש בשירות ה-Internet-ID הציבורי שלנו, ודא שהשרת הראשי ב- id.remoteutilities.com נגיש מהמחשב המרוחק .

  1. לחץ על Win+R כדי לפתוח את חלון "הריצה".
  2. הקלד cmd ולחץ OK (או הקש Enter). יח.window של שורת הפקודה תיפתח.
  3. הקלד ping id.remoteutilities.com והקש Enter.
  4. אם פקודת ה-ping ופתרון ה-DNS מצליחים, התוצאה תוצג בחלון ה-CMD: Ping שרת ID
  5. אם אתה מקבל "Request timed out" כתגובה, השרת ID אינו נגיש ממיקום ה-Host. נא, פנה למנהל המערכת שלך.

פתרון 3: ודא שיציאות החיבור מותרות

חיבור ה-Internet-ID דורש שיציאות יציאה יהיו פתוחות. כאשר הוא בשימוש עם השירות הציבורי שלנו, היציאות הפעולות הן TCP 5655 ו-443. ודא שה-Host יכול לקבוע חיבורי יציאה על יציאות אלה או אפשר את היציאות בחומת האש המקומית ובחומת האש הגבול אם יש צורך.

גם אם חיבורי היציאה על יציאות TCP 5655 ו-443 מותרים במחשב ה-Host ובחומת האש הגבול, עדיין ייתכן כי חיבורים כאלה חסומים ברמה של ספק השירות. במקרה כזה עליך לפנות לנציג ספק השירות שלך.

תגים: שגיאה, חיבוריות