Nie można połączyć się po aktualizacji do Windows 10
Objawy
Po zaktualizowaniu komputera Host do Windows 10 z XP, Vista lub Win 7 przy użyciu Windows Update, nie możesz już połączyć się z Hostem, mimo że działa w systemie.
Przyczyna
Problem ten dotyczy wersji Remote Utilities 6.3.0.6 i starszych, w których ustawienia Host znajdowały się w kluczu rejestru HKEY_LOCAL_MACHINE/SYSTEM/Remote Utilities
. Klucz ten zawiera również informacje o kodzie Internet-ID oraz haśle dostępu (w formie zabezpieczonej). Podczas aktualizacji do Windows 10 Windows usuwa/resetuje klucz, a ustawienia Host są opróżniane.
Począwszy od wersji 6.5, ustawienia Host znajdują się w kluczu HKEY_LOCAL_MACHINE/Software/Usoris
, a więc ustawienia te nie są dotknięte aktualizacjami Windows.
Rozwiązanie 1
Zaktualizuj Remote Utilities do najnowszej wersji. Postępuj zgodnie z tym przewodnikiem aktualizacji.
Rozwiązanie 2
Skorzystaj z tego rozwiązania, jeśli chcesz zachować swoją obecną wersję (6.5 i starsze).
- Pobierz skrypt
export.cmd
na komputerze Host.Uwaga:
Niektóre przeglądarki internetowe mogą natychmiast otworzyć plik do podglądu, zamiast pobrać go na dysk. Aby pobrać plik, kliknij prawym przyciskiem myszy na link do pobrania i wybierz Zapisz link jako... lub podobną komendę w swojej przeglądarce internetowej, aby pobrać plik.
- Kliknij prawym przyciskiem myszy na plik
export.cmd
i wybierz Uruchom jako administrator w menu kontekstowym Windows. - Kiedy pojawi się okno CMD, naciśnij dowolny klawisz, aby uruchomić skrypt. Plik
ru_settings.reg
z ustawieniami Host zostanie zapisany w tym samym katalogu, co plik skryptu. - Zaktualizuj do Windows 10.
- Pobierz skrypt
import.cmd
na komputerze Host. - Kliknij prawym przyciskiem myszy na plik
import.cmd
i wybierz Uruchom jako administrator w menu kontekstowym Windows. - Kiedy pojawi się okno CMD, naciśnij dowolny klawisz, aby uruchomić skrypt. Skrypt zaimportuje ustawienia Host z powrotem do rejestru. Alternatywnie, możesz dwukrotnie kliknąć na plik
ru_settings.reg
, aby zaimportować ustawienia do rejestru. - Możesz albo zrestartować Host (kliknij prawym przyciskiem myszy na ikonę Host i wybierz Restartuj Host), albo zrestartować komputer Host.