Não é possível conectar após a atualização para Windows 10
Sintomas
Após atualizar o PC Host para Windows 10 a partir do XP, Vista ou Win 7 usando o Windows Update, você não consegue mais conectar ao Host, apesar de ele estar em funcionamento no sistema.
Causa
Este problema afeta a versão 6.3.0.6 do Remote Utilities e versões anteriores, onde as configurações do Host costumavam estar localizadas na chave de registro HKEY_LOCAL_MACHINE/SYSTEM/Remote Utilities
. A chave também contém informações sobre o código Internet-ID e a senha de acesso (em uma forma segura). Durante uma atualização do Windows 10, o Windows exclui/redefine a chave e as configurações do Host são esvaziadas.
A partir da versão 6.5, as configurações do Host residem na chave HKEY_LOCAL_MACHINE/Software/Usoris
e, portanto, as configurações não são afetadas pela atualização do Windows.
Solução 1
Atualize o Remote Utilities para a versão mais recente. Siga este guia de atualização.
Solução 2
Use esta solução se você quiser manter sua versão atual (6.5 ou anterior).
- Baixe o script
export.cmd
no computador Host.Nota:
Alguns navegadores da web podem abrir imediatamente o arquivo para visualização, em vez de baixá-lo para o disco. Para baixar o arquivo, clique com o botão direito no link de download e selecione Salvar link como... ou um comando similar no seu navegador web para baixar o arquivo.
- Clique com o botão direito no arquivo
export.cmd
e escolha Executar como administrador no menu de contexto do Windows. - Quando a janela CMD aparecer, pressione qualquer tecla para executar o script. O arquivo
ru_settings.reg
com as configurações do Host será salvo no mesmo diretório que o arquivo do script. - Atualize para o Windows 10.
- Baixe o script
import.cmd
no computador Host. - Clique com o botão direito no arquivo
import.cmd
e escolha Executar como administrador no menu de contexto do Windows. - Quando a janela CMD aparecer, pressione qualquer tecla para executar o script. O script importará as configurações do Host de volta para o registro. Alternativamente, você pode clicar duas vezes no arquivo
ru_settings.reg
para importar as configurações para o registro. - Reinicie o Host (clique com o botão direito no ícone do Host e selecione Reiniciar Host) ou reinicie o PC Host.