Cannot connect after upgrading to Windows 10
Symptoms
After upgrading the Host PC to Windows 10 from XP, Vista or Win 7 using Windows Update you can no longer connect to the Host despite it is running in the system.
Cause
This problem affects Remote Utilities version 6.3.0.6 and older where the Host settings used to be located in the registry key HKEY_LOCAL_MACHINE/SYSTEM/Remote Utilities
. The key also contains information about the Internet-ID code and the access password (in a secure form). During a Windows 10 upgrade, Windows deletes/resets the key and the Host settings are emptied.
Starting with version 6.5 the Host settings reside in the HKEY_LOCAL_MACHINE/Software/Usoris
key instead and so the settings are not affected by Windows update.
Solution 1
Update Remote Utilities to the latest version. Follow this update guide.
Solution 2
Use this solution if you want to keep your current version (6.5 and earlier).
- Download the
export.cmd
script onto the Host computer.Note:
Some web browsers may immediately open the file for viewing, instead of downloading it to the disk. To download the file, right-click on the download link and select Save link as... or a similar command in your web browser to download the file.
- Right-click on the
export.cmd
file and choose Run as administrator in the Windows context menu. - When the CMD window appears press any key to run the script. The file
ru_settings.reg
with Host settings will be saved to the same directory as the script file. - Upgrade to Windows 10.
- Download the
import.cmd
script on the Host computer. - Right-click on the
import.cmd
file and choose Run as administrator in the Windows context menu. - When the CMD window appears press any key to run the script. The script will import the Host settings back into the registry. Alternatively, you can double click on the
ru_settings.reg
file to import the settings to the registry. - Either restart the Host (right-click the Host icon and select Restart Host) or restart the Host PC.